FME - MAPublisher Compatibility

There are several interactions between FME, Adobe Illustrator, and MAPublisher that are important for the MAPublisher FME Auto plugin to function correctly. When multiple versions of FME and Adobe Illustrator are installed on a single machine, you should be aware of compatibility issues.

Compatibility 1: FME version vs FME Auto plugin version


The FME version that the FME Auto plugin is built against needs to be the same or older than the FME version it is installed for. FME ships with the FME Auto plugin that is compatible with that version. If MAPublisher is installed afterwards, the plugin will be overwritten. MAPublisher comes with plugins built against all supported versions of FME.


Troubleshoot issue:

If the FME Auto plugin is built against a newer FME version than the FME version installed, it won’t load and won’t be available in the list of writers. If the FME Auto plugin is built against an older version of FME, it will work, however, a warning will be issued to the FME log. This should not be an issue unless the FME plugin is manually copied into the FME folder.



Compatibility 2: FFS version vs extending FME version


MAPublisher needs to be extended by FME in order to be able to read FFS files. The extending FME version should be the same or newer than the version of FME Workbench that triggers MAPublisher/Adobe Illustrator. If multiple versions of FME are installed, good practice is to use the most recent FME version to extend MAPublisher.


Troubleshoot issue:

If FFS files were created by the FME Auto plugin from within a newer version of FME Workbench, MAPublisher/Adobe Illustrator may fail to read them (e.g. “Cannot read schema” error). For example, MAPublisher is extended by FME 2011, and the user tries to run an FME 2015 workspace with a MAPublisher writer. When the process triggers MAPublisher an error may be displayed as FME 2011 may not be able to read the FS file created by FME 2015.


If FME and Adobe Illustrator must be installed to accommodate different system architecture (i.e. 32-bit vs 64-bit), MAPublisher needs to be extended by FME with the same architecture. Full installation is recommended, however, a redistributable could be used instead. The version extending FME must be the same or newer than the FFS file it is trying to read.

For example, 32-bit FME needs to be installed to read ArcGIS Personal Geodatabases, but 64-bit Illustrator is installed to access larger amounts of system memory. 64-bit FME could be installed and used to extend Illustrator (which is recommended), or a 64-bit redistributable could be used. This problem can be identified by FME displaying an error about MAPublisher not being extended. Also, the FME category would be absent in MAPublisher Preferences.


Compatibility 3: FME Auto plugin and installed Adobe Illustrator versions


FME Auto needs to be aware of which Adobe Illustrator versions are available in order to find it and send data to them. If FME Auto has not be built since the latest release of Illustrator it may not be able to discover it in the system.


Troubleshoot issue:

FME Auto plugin displays an error that it cannot locate the most recent Adobe Illustrator version or uses a previous version of it instead (if installed).



Compatibility 4: FME Auto plugin and installed MAPublisher versions


The FME Auto plugin and MAPublisher versions need to be compatible. An older FME Auto plugin version may not have the all the features that MAPublisher expects, so defaults will be used. A newer version will have features MAPublisher may not be able to take advantage of, so they will be ignored.


Troubleshoot issue:

Newer FME Auto plugin settings fail to take effect in MAPublisher.